POODLE Attack Leaves Browser Users Vulnerable, Especially When Using Open, Unencrypted Networks

News Security Threats

POODLE Attack Leaves Browser Users Vulnerable, Especially When Using Open, Unencrypted Networks

Earlier this month a newly discovered flaw was discovered by Google researchers that exploits an outdated encryption protocol, Secure Sockets Layer version 3 (SSLv3). SSLv3 protects secure web links and safeguards connections your browser makes to financial institutions, email providers …